Showing posts with label iCalendar. Show all posts
Showing posts with label iCalendar. Show all posts
January 8, 2008
December 27, 2007
December 17, 2007
mew-ical.el
先日の続き。認証の有無を認識するようにして、必要ならパスワードの入力を求めるようにしてみた。それからMETHOD:REPLYな.icsファイルの場合には、リクエストに対する相手のステータスを表示するようにした。
ファイルは前回と同じ場所に置いた。
ファイルは前回と同じ場所に置いた。
December 14, 2007
MewでiCalendar形式のファイルに対応させる
必要に迫られてMewでiCalendar形式のファイルが添付されてきた場合に、設定したカレンダーサーバに対して予定の登録および承認の可否をできるようにしてみた。現時点でできることは、
- iCalendarの情報を(気持ち)分かりやすく表示する
- 自分のカレンダーサーバへ登録する
- ステータスの更新
- Mewからカレンダーサーバへアクセスする
- 承諾の可否を選択した後、要求者に対してメールで返信すること
- 排他制御
- カレンダーサーバに対する認証の有無の自動検出
- ローカル時間で表示すること
- その他多数
- emacs
- mew
- browse-url
- curl
- iTIPをサポートしたカレンダーサーバ
December 5, 2007
iCalendar関係のメモ
- RFC2445 Internet Calendaring and Scheduling Core Object Specification (iCalendar)
- RFC2446 iCalendar Transport-Independent Interoperability Protocol (iTIP) Scheduling Events, BusyTime, To-dos and Journal Entries
- RFC2447 iCalendar Message-Based Interoperability Protocol (iMIP)
- RFC3283 Guide to Internet Calendaring
Subscribe to:
Posts (Atom)